Právě je 14 srp 2020 22:06

Všechny časy jsou v UTC + 1 hodina [ Letní čas ]




Odeslat nové téma Odpovědět na téma  [ Příspěvků: 3 ] 
Autor Zpráva
 Předmět příspěvku: PrestaShop 1.7.6.7 - HTTP ERROR 500 po upgrade modulu
PříspěvekNapsal: 18 črc 2020 19:49 
C4 zákazník

Registrován:
18 črc 2020 19:18
Příspěvky:
2
Zdravím,
dnes nám po aktualizaci modulů přestal fungovat eshop (přes tlačítko upgrade u modulu). Nefunguje ani frontoffice ani backoffice.
Promazali jsme cache, avšak bez účinku.
Řešili jste někdo něco podobného? Verze presty 1.7.6.7.

Při pokusu o načtení backoffice se objeví tato informace:
Kód:
(1/1) ClassNotFoundException
Attempted to load class "ComposerAutoloaderInitef3eaa4e044585d88a3761f4f33579fe" from the global namespace.
Did you forget a "use" statement?


Při pokusu o načtení frontoffice se objeví (již máme debugovací mód, doménu jsme přepsali, kvůli bezpečnosti):
Kód:
Fatal error: Uncaught Error: Class 'ComposerAutoloaderInitef3eaa4e044585d88a3761f4f33579fe' not found in /data/www/domena.cz/www.domena.cz/modules/blockreassurance/vendor/autoload.php:7 Stack trace: #0 /data/www/domena.cz/www.domena.cz/src/Adapter/ContainerBuilder.php(236): include_once() #1 /data/www/domena.cz/www.domena.cz/src/Adapter/ContainerBuilder.php(129): PrestaShop\PrestaShop\Adapter\ContainerBuilder->loadModulesAutoloader(Object(FrontContainer)) #2 /data/www/domena.cz/www.domena.cz/src/Adapter/ContainerBuilder.php(93): PrestaShop\PrestaShop\Adapter\ContainerBuilder->buildContainer('front') #3 /data/www/domena.cz/www.domena.cz/classes/controller/FrontController.php(1968): PrestaShop\PrestaShop\Adapter\ContainerBuilder::getContainer('front', true) #4 /data/www/domena.cz/www.domena.cz/classes/controller/Controller.php(184): FrontControllerCore->buildContainer() #5 /data/www/domena.cz/www.domena.cz/classes/controller/FrontController.php(271): ControllerCore->init() #6 /data/www/domena.cz/www.domena.c in /data/www/domena.cz/www.domena.cz/modules/blockreassurance/vendor/autoload.php on line 7


Příště budeme provádět zálohu před každou aktualizací modulu.
Děkujeme za reakce.


Nahoru
 Profil  
 
 Předmět příspěvku: Re: PrestaShop 1.7.6.7 - HTTP ERROR 500 po upgrade modulu
PříspěvekNapsal: 18 črc 2020 21:44 
C4 zákazník

Registrován:
18 črc 2020 19:18
Příspěvky:
2
Update pro ty, kdo by řešili podobný problém.

Problém byl zřejmě v aktualizaci modulu.
V FTP jsem ve složce modules odstranil blockreassurance modul (složku).
Poté jsem odstranil dvě tabulky z MySQL databáze - ps_psreassurance a ps_psreassurance_lang
Znovu jsem pročistil cache - promazal obsah ve složce /var/cache
Náhle se vše rozběhlo.
V katalogu modulů jsem pak modul znovu nainstaloval a nainstalovala se již aktuální verze.


Nahoru
 Profil  
 
 Předmět příspěvku: Re: PrestaShop 1.7.6.7 - HTTP ERROR 500 po upgrade modulu
PříspěvekNapsal: 20 črc 2020 10:29 
C4 podpora
C4 podpora

Registrován:
30 čer 2009 09:14
Příspěvky:
7669
Dobrý den,

výborně, děkuji za uvedení řešení i pro ostatní uživatele.

_________________
Radek Plašil
Webhosting C4
https://www.c4.cz/


Nahoru
 Profil  
 
Zobrazit příspěvky za předchozí:  Seřadit podle  
Odeslat nové téma Odpovědět na téma  [ Příspěvků: 3 ] 

Všechny časy jsou v UTC + 1 hodina [ Letní čas ]


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků


Nemůžete zakládat nová témata v tomto fóru
Nemůžete odpovídat v tomto fóru
Nemůžete upravovat své příspěvky v tomto fóru
Nemůžete mazat své příspěvky v tomto fóru
Nemůžete přikládat soubory v tomto fóru

Hledat:
Přejít na:  
FTP Uploader
Staňte se naším zákazníkem!
Hledáme kolegy
PrestaShop partneři

Seznam všech partnerů

PrestaShop Hosting
Návody pro C4

© 2009-2020 ČESKÝ WEBHOSTING s.r.o. Kontaktní e-mail: forum@c4.cz
Diskuzní fórum využívá technologie: phpBB, phpBB-SEO.com, phpBB.cz