Právě je 14 srp 2018 23:11

Všechny časy jsou v UTC + 1 hodina [ Letní čas ]




Odeslat nové téma Odpovědět na téma  [ Příspěvků: 3 ] 
Autor Zpráva
 Předmět příspěvku: PrestaShop 1.7.4.1 - Chyba 500 s modulem SmartBlog
PříspěvekNapsal: 29 črc 2018 17:23 
C4 zákazník

Registrován:
17 říj 2017 23:07
Příspěvky:
32
Dobrý den, řeším na eshopu jednu zvláštní věc. Jde o rozšířený modul SmartBlog. Při kliknutí na tlačítko "Blog Post" v administraci dostanu zvláštní chybu (zřejmě od hostingu) a v PHP logu je:

[Sun Jul 29 17:14:44 2018] [error] [client 90.178.167.47] PHP Fatal error: Declaration of AdminBlogPostController::setMedia() must be compatible with AdminControllerCore::setMedia($isNewTheme = false) in /data/www/mujweb.cz/www.mujweb.cz/modules/smartblog/controllers/admin/AdminBlogPostController.php on line 638, referer: https://www.mujweb.cz/adminxx/index.php ... 801ed4f053
[Sun Jul 29 17:14:44 2018] [error] [client 90.178.167.47] PHP Warning: realpath(): open_basedir restriction in effect. File(/etc/cgi-bin/www/applessories.cz/www.applessories.cz) is not within the allowed path(s): (/data/www/mujweb.cz/:/usr/local/php-7.2/lib/) in /data/www/mujweb.cz/www.mujweb.cz/src/PrestaShopBundle/Twig/Locator/ModuleTemplateLoader.php on line 49, referer: https://www.mujweb.cz/adminxx/index.php ... 801ed4f053

To zvláštní je, že pokud zkopíruji web na localhost a spustím přes MAMP, tak to funguje.
Nedokážete mi prosím poradit, čím by to mohlo být? Jediné co mě napadlo, jestli by to nemohlo být přepnutím na PHP 7.2, ale Presta 1.7.4.1 by měla být kompatibilní.


Nahoru
 Profil  
 
 Předmět příspěvku: Re: PrestaShop 1.7.4.1 - Chyba 500 s modulem SmartBlog
PříspěvekNapsal: 02 srp 2018 13:47 
C4 podpora
C4 podpora

Registrován:
30 čer 2009 09:14
Příspěvky:
6723
Dobrý den,

testoval jsem funkčnost modulu na poslední verzi aplikace 1.7.4.2 a žádný problém nenastal. Zkuste tedy provést aktualizaci aplikace na novější verzi.

_________________
Radek Plašil
Webhosting C4
https://www.c4.cz/


Nahoru
 Profil  
 
 Předmět příspěvku: Re: PrestaShop 1.7.4.1 - Chyba 500 s modulem SmartBlog
PříspěvekNapsal: 06 srp 2018 15:56 
Uživatelský avatar

Registrován:
03 bře 2011 23:21
Příspěvky:
530
PrestaShop kompatibilní s PHP 7.2 (asi) je, ale SmartBlog ne. V této verzi je striktně vyžadováno, že funkce mají stejné parametry a to způsobuje tu fatální chybu.

_________________
GDPR | EET | PDF rozšíření | Money S3 | Pohoda | Služby
Obrázek
https://www.presta-addons.com


Nahoru
 Profil  
 
Zobrazit příspěvky za předchozí:  Seřadit podle  
Odeslat nové téma Odpovědět na téma  [ Příspěvků: 3 ] 

Všechny časy jsou v UTC + 1 hodina [ Letní čas ]


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 1 návštěvník


Nemůžete zakládat nová témata v tomto fóru
Nemůžete odpovídat v tomto fóru
Nemůžete upravovat své příspěvky v tomto fóru
Nemůžete mazat své příspěvky v tomto fóru
Nemůžete přikládat soubory v tomto fóru

Hledat:
Přejít na:  
FTP Uploader
Staňte se naším zákazníkem!
Hledáme kolegy
PrestaShop partneři

Seznam všech partnerů

PrestaShop Hosting
Návody pro C4

© 2009-2018 ČESKÝ WEBHOSTING s.r.o. Kontaktní e-mail: forum@c4.cz
Diskuzní fórum využívá technologie: phpBB, phpBB-SEO.com, phpBB.cz